Advancement Form Inaccessible
Incident Report for Advancement Form
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 22:42 EDT
Monitoring
At 8:38 EDT, Advancement Form became inaccessible. The issue was related to two highly complex forms with over 700 fields that was distributed to thousands of users. As a result, the system could not withstand the load. We disabled these forms to allow the system to recover. The system was back to normal at 9:02 EDT. We will be selectively re-enabling these forms and monitoring the system performance.
Posted Apr 20, 2021 - 21:32 EDT
This incident affected: Application.